Home

Awesome

Support me and this project

Hi, this is Johnny, I'm an Engineering student. Life and university studies are expensive and the work is hard. My repositories are free, please consider rewarding me. Thank you.

4 ways to support me:

  1. Donate BTC: 3R13Ye85VwuzrBEJf32dZgREHsFsFpoG4m
  2. Donate ETH: 0x13f430523CAB662faA6924D6fbA4FdFA973A693b
  3. Please give me feedback: Open (or help with) issues or fork and send a pull request if you find some improvements to be made!

EFI Folder for the iaomi Notebook Air 2016 13.3""

MacOS Versions Supported:

What do I need?

What is Working?

Half working:

Not working:

Installation

Sounds good! Where do we start? You need a computer with macOS or Windows (scroll down)

Clover or OpenCore?

First let's figure out if we would like to use Clover or OpenCore. The pro's / con's listed:

Clover

Pro's (+)

Con's (-)

OpenCore

Pro's (+)

Con's (-)

Installing from macOS:

Clover method:

diskutil list
sudo diskutil mount /dev/disk3s1
diskutil list
sudo diskutil mount /dev/disk0s1
sudo chmod -R 755 /System/Library/Extensions/
sudo chown -R root:wheel /System/Library/Extensions/
sudo chmod -R 755 /Library/Extensions/
sudo chown -R root:wheel /Library/Extensions/
sudo touch /System/Library/Extensions/
sudo touch /Library/Extensions/
sudo kextcache -i / && sudo kextcache -u /

OpenCore method:

diskutil list
sudo diskutil mount /dev/disk3s1
diskutil list
sudo diskutil mount /dev/disk0s1

From Windows:

Clover method:

Downloading macOS:

Making the installer USB stick:

Making the USB stick Xiaomi compatible:

Installing macOS:

diskutil list
sudo diskutil mount /dev/disk0s1
sudo chmod -R 755 /System/Library/Extensions/
sudo chown -R root:wheel /System/Library/Extensions/
sudo chmod -R 755 /Library/Extensions/
sudo chown -R root:wheel /Library/Extensions/
sudo touch /System/Library/Extensions/
sudo touch /Library/Extensions/
sudo kextcache -i / && sudo kextcache -u /

OpenCore method:

Downloading macOS:

Making the installer USB stick:

Making the USB stick Xiaomi compatible:

Installing macOS:

diskutil list
sudo diskutil mount /dev/disk0s1

macOS is working! Next steps:

(optional) Fixing iMessage, FaceTime etc.

This can be a bit of a challenge, and outside of the scope of this repo, but if you want to, have a look here:<br /> An iDiot's Guide To iMessage (clover)<br /> Fixing iServices (OpenCore)

(optional) WiFi

Still very buggy, but improving fast. Have a look here

If your Intel Wifi not working, please be patient.

(optional) Hackintosh combojack how to

hackintosh-stuff thanks to his repository we can fix the headphone jack: https://github.com/hackintosh-stuff/ComboJack

(optional) High DPI display fix:

Since the text on the 13" display can be quite small for many people in 1920x1080 resolution, it's possible to use some of the High DPI scaling features of macOS. To enable those:

csrutil disable
bash -c "$(curl -fsSL https://github.com/johnnync13/Xiaomi-Mi-Air/raw/master/HighDPI/hidpi.sh)"
csrutil enable

Troubleshooting

Some device in my system is not working under macOS!

Using Clover:

sudo chmod -R 755 /System/Library/Extensions/
sudo chown -R root:wheel /System/Library/Extensions/
sudo chmod -R 755 /Library/Extensions/
sudo chown -R root:wheel /Library/Extensions/
sudo touch /System/Library/Extensions/
sudo touch /Library/Extensions/
sudo kextcache -i / && sudo kextcache -u /

Using OpenCore:

IMPORTANT:

BIOS Modification

Tutorial to modify BIOS

First of all, I am not responsible for what can happen to your laptop

1- Boot with OpenCore
2- Click on space key on keyboard.
3- Select partition Mod Grub Shell
4- Write a command method, for example to unlock cfg lock: setup_var 0x3C 0x00
Other example, SpeedShift to enable: setup_var 0xB 0x01
it is possible that for example, SpeedShift is enabled before.

setup_var is to call method function.
0x3C is the location memory on bios that is variable CFG Lock.
0x00 is to disable and 0x01 is to enable. I put the example here.
(default) is how the variable is when you install a BIOS, that is, by the manufacturer.

One Of: CFG Lock, VarStoreInfo (VarOffset/VarName): 0x3C, VarStore: 0x3, QuestionId: 0x146, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 8A 02 8B 02 46 01 03 00 3C 00 10 10 00 01 00}
0x149413 One Of Option: Disabled, Value (8 bit): 0x0 {09 07 04 00 00 00 00}
0x14941A One Of Option: Enabled, Value (8 bit): 0x1 (default) {09 07 03 00 30 00 01}
0x149421 End One Of {29 02}

5- You can set up more variables to modify Bios. If you want exit, you must write reboot and click enter on keyboard.

6- You can verify the CFG is unlocked or other parametres like SpeedShift is enabled in hackintool, section Utilities and press button Get AppleIntelInfo.

Disclaimer!

Use these files and this howto at your own risk. I'm not responsible in any way for lost data, damage to software or hardware or anything else that might go wrong. This works for me but might not for you.

Credits