Home

Awesome

Support me and this project

Hi, I'm Johnny, I'm an Computer Engineering and Data Scientist. Life and university studies are expensive and the work is hard. My repositories are free, please consider rewarding me. Thank you.

4 ways to support me:

  1. Donate BTC: 3R13Ye85VwuzrBEJf32dZgREHsFsFpoG4m
  2. Donate ETH: 0x13f430523CAB662faA6924D6fbA4FdFA973A693b
  3. Please give me feedback: Open (or help with) issues or fork and send a pull request if you find some improvements to be made!

EFI Folder for the Xiaomi Mi Notebook Air 13.3" 2018

MacOS Versions Supported:

What do I need?

sudo kextload -v /Volumes/USB/HoRNDIS.kext

What is Working?

Half working:

Not working:

Installation

Sounds good! Where do we start? You need a computer with macOS or Windows (scroll down)

Clover or OpenCore?

First let's figure out if we would like to use Clover or OpenCore. The pro's / con's listed:

Clover

Pro's (+)

Con's (-)

OpenCore

Pro's (+)

Con's (-)

Installing from macOS:

Clover method:

diskutil list
sudo diskutil mount /dev/disk3s1
diskutil list
sudo diskutil mount /dev/disk0s1
sudo chmod -R 755 /System/Library/Extensions/
sudo chown -R root:wheel /System/Library/Extensions/
sudo chmod -R 755 /Library/Extensions/
sudo chown -R root:wheel /Library/Extensions/
sudo touch /System/Library/Extensions/
sudo touch /Library/Extensions/
sudo kextcache -i / && sudo kextcache -u /

OpenCore method(Only mode supported by this repo):

diskutil list
sudo diskutil mount /dev/disk3s1
python3 -c 'import secrets; print(secrets.randbits(64))'
diskutil list
sudo diskutil mount /dev/disk0s1

NOTE

From Windows:

Clover method:

Downloading macOS:

Making the installer USB stick:

Making the USB stick Xiaomi compatible:

Installing macOS:

diskutil list
sudo diskutil mount /dev/disk0s1
sudo chmod -R 755 /System/Library/Extensions/
sudo chown -R root:wheel /System/Library/Extensions/
sudo chmod -R 755 /Library/Extensions/
sudo chown -R root:wheel /Library/Extensions/
sudo touch /System/Library/Extensions/
sudo touch /Library/Extensions/
sudo kextcache -i / && sudo kextcache -u /

OpenCore method:

Downloading macOS:

Making the installer USB stick:

Making the USB stick Xiaomi compatible:

Installing macOS:

diskutil list
sudo diskutil mount /dev/disk0s1

NOTE

macOS is working! Next steps:

(optional) Fixing iMessage, FaceTime etc.

This can be a bit of a challenge, and outside of the scope of this repo, but if you want to, have a look here:<br /> An iDiot's Guide To iMessage (clover)<br /> Fixing iServices (OpenCore)

(optional) WiFi

Still very buggy, but improving fast. Have a look here

If your Intel Wifi not working, please be patient, the driver is getting better really fast. Until then, use a macOS compatible USB Wifi dongle or Ethernet adapter.

(optional) Garbled Audio Problems

If you're having audio problems, especially with headphones, read more about it under Audio

(optional) Display Color Profile:

Read more in Display

(optional) High DPI display fix:

Read more in Display

Troubleshooting

I have a problem an don't know what to do!

Please read the issues section, and only if your question is not yet answered, submit a new one.

Some device in my system is not working under macOS!

Using Clover:

sudo chmod -R 755 /System/Library/Extensions/
sudo chown -R root:wheel /System/Library/Extensions/
sudo chmod -R 755 /Library/Extensions/
sudo chown -R root:wheel /Library/Extensions/
sudo touch /System/Library/Extensions/
sudo touch /Library/Extensions/
sudo kextcache -i / && sudo kextcache -u /

Using OpenCore:

Disclaimer!

Use these files and this howto at your own risk. I'm not responsible in any way for lost data, damage to software or hardware or anything else that might go wrong. This works for me but might not for you.

Credits